Wirelessinfo.be

Mikrotik VRRP instellingen

vrrp

Als je in uw netwerk redundant internet wil inbouwen kan je dit doen door middel van twee routers en een switch. In dit voorbeeld kan men zelfs een tweede ISP als reserve nemen. Bij defect van router 1 kan het data verkeer naar internet omgeleid worden door router 2 zodat het netwerk niet zonder internet komt te zitten. Dit kan men bereiken met VRRP.

Werking

Router 1 staat in verbinding met ISP1. Router2 staat in verbinding met ISP2. Beide routers zijn verbonden met elkaar via een switch en zitten in dezelfde IP-range. Zolang router 1 functioneel is, wordt alle verkeer dat bestemd is voor het externe netwerk omgeleid naar router 1. Zodra Router 1 faalt, neemt router 2 het over maar de standaard gateway (in dit voorbeeld 192.168.1.254) wordt behouden. Zolang router 1 actief is blijft router 2 inactief deze fungeert uitsluitend als reserve voor redundantie. Beide routers controleren elkaar door heartbeat of ze nog werkend zijn. Als router2 router1 nog ziet via de heartbeat is alles ok en verloopt al het verkeer via router1. Als router2 geen heartbeat meer ontvangt van router 1 schakelt deze over en schakelt het vitueel IP-adres aan die als gateway dienst doet. Ontvangt router2 opnieuw de heartbeat van router1 schakelt die het virtueel Ip terug uit en gaat alles via router1. Dit verhoogt de beschikbaarheid en betrouwbaarheid van routeringspaden via automatische standaard gateway selecties op een IP-subnetwerk.

Voorbeeld

Router 1 heeft als IP-adres 192.168.1.1/24

Router1 heeft een DHCP-server in de 192.168.1.0/24 range en heeft een internet uplink ISP1.

Router 2 heeft als IP-adres 192.168.1.2/24 en heeft als internet uplink ISP2.

Het virtueel IP-adres 192.168.1.254/32 fungeert als standaard gateway.

Het volstaat deze code in het terminal venster te plakken indien je dezelfde IP-adressen gaat gebruiken. Anders moet je de IP-adressen aanpassen.

Het instellen van de hoofd router
Router1 de hoofd router
  • /ip address add address=192.168.1.1/24 interface=ether1
  • /interface vrrp add interface=ether1 vrid=49 priority=254
  • /ip address add address=192.168.1.254/32 interface=vrrp1
Wat meer in detail met printscreens

vrrp

Klik op "IP" vervolgens op "addresses".

vrrp

Klik op het blauwe kruis.

vrrp

Selecteer "ether1" bij address geef het IP-adres 192.168.1.1/24 in. Klik op "OK".

Virtual Router Redundancy Protocol instellen
vrrp

Klik op "interface" klik verder door op het tabblad "VRRP".

vrrp

Klik op het blauwe kruis om een VRRP interface aan te maken.

vrrp

Bij "name" kan je VRRP een naam geven, voor de rest laat alles zoals het is. Klik door op het tabblad "VRRP".

vrrp

Bij interface selecteer je "ether1".

vrrp

  • Bij "VRID" (virtual router identification) vul je 49 in.
  • Bij priority laat 254 staan.
  • Wat preemption mode betreft: Telkens wanneer een router met hogere prioriteit beschikbaar wordt, wordt deze de master router. Soms is dit niet gewenst en kan je deze instelling uitschakelen door "preemption mode" uit te vinken. In dit voorbeeld werken we maar met twee routers we laten dat aangevinkt staan.
  • Klik op "ok".

vrrp

Je ziet dat de vrrp interface nog in het rood staat. Dit komt omdat er nog geen IP-adres is toegewezen aan deze interface.

vrrp

Klik in het hoofd venster op "IP" vervolgens op "addresses".

vrrp

Klik op het blauwe kruisje.

vrrp

Bij interface selecteer "vrrp"

vrrp

Bij "address" vul je het IP-adres 192.168.1.254/32 in. Dit wordt onze virtuele gateway.

vrrp

Nu is de VRRP interface normaal gekleurd en in orde.

De internet toegang realiseren op de master router
vrrp

Klik in het hoofd venster op "ip" vervolgens op "DHCP-client".

vrrp

Klik op het blauwe kruis.

vrrp

Selecteer de interface dat is verbonden met de internet modem. In dit voorbeeld "ether2". Klik op "ok".

vrrp

De Interface ether2 van de master router is nu verbonden met ISP1. Nu moet de WAN en LAN genat en gemaskeerd worden.

vrrp

Klik op het hoofd venster op "IP" vervolgens op "firewall".

vrrp

Klik op het tabblad "NAT" en klik op het blauwe kruis.

vrrp

  • Bij "chain" selecteer "srcnat".
  • Bij "Scr.address" geef de volledige IP-range in van de lan. In dit voorbeeld 192.168.1.0/24
  • Bij "out interface" selecteer je de interface dat verbonden is met de internet modem. Hier is dit "ether2".
  • Klik verder op het tabblad "action".

vrrp

Selecteer bij "action" "masquerade" en klik op "ok".

De instellingen zijn gemaakt. Op de switch moet nog een DHCP-server worden geinstalleerd. Als standaard gateway geef je het IP-adres 192.168.1.254 in.

Het instellen van de backup router
Router2 de backup router
  • /ip address add address=192.168.1.2/24 interface=ether1
  • /interface vrrp add interface=ether1 vrid=49
  • /ip address add address=192.168.1.254/32 interface=vrrp1

De werkwijze verduidelijkt met printscreens
vrrp

Klik op "IP" vervolgens op "addresses".

vrrp

Om de router een IP-adres te geven selecteer je "ether1" geef bij "Address" het IP 192.168.1.2/24 in. Klik op "ok".

Virtual Router Redundancy Protocol instellen
vrrp

Klik op "interfaces" vervolgens klik op het tabblad "vrrp".

vrrp

Klik op het blauwe kruis om een VRRP interface aan te maken.

vrrp

Bij "name" kan je VRRP een naam geven, voor de rest laat alles zoals het is. Klik door op het tabblad "VRRP".

vrrp

  • Bij "VRID" (virtual router identification) vul je 49 in. Deze virtual router identificatie moet dezelfde zijn dan de master router.
  • Bij priority laat dit onaangeroerd.
  • Wat preemption mode betreft: Telkens wanneer een router met hogere prioriteit beschikbaar wordt, wordt deze de master router. Soms is dit niet gewenst en kan je deze instelling uitschakelen door "preemption mode" uit te vinken. In dit voorbeeld werken we maar met twee routers de master router en de backup router we laten dat aangevinkt staan.
  • Klik op "ok".

vrrp

Klik in het hoofd venster op "IP" vervolgens op "addresses".

vrrp

Klik op het blauwe kruisje.

vrrp

Bij interface selecteer "vrrp"

vul je het IP-adres 192.168.1.254/32

Bij "address" vul je het IP-adres 192.168.1.254/32 in. Dit wordt onze virtuele gateway. Deze gateway is zowel op de master router als backup router hetzelfde IP-adres.

Internet toegang configureren op de backup router.
vrrp

Klik in het hoofd venster op "ip" vervolgens op "DHCP-client".

vrrp

Klik op het blauwe kruis.

vrrp

Selecteer de interface dat is verbonden met de internet modem. In dit voorbeeld "ether2". Klik op "ok".

vrrp

De Interface ether2 van de backup router is nu verbonden met ISP2. Nu moet de WAN en LAN genat en gemaskeerd worden.

vrrp

Klik op het hoofd venster op "IP" vervolgens op "firewall".

vrrp

Klik op het tabblad "NAT" en klik op het blauwe kruis.

vrrp

  • Bij "chain" selecteer "srcnat".
  • Bij "Scr.address" geef de volledige IP-range in van de lan. In dit voorbeeld 192.168.1.0/24
  • Bij "out interface" selecteer je de interface dat verbonden is met de internet modem. Hier is dit "ether2".
  • Klik verder op het tabblad "action".

vrrp

Selecteer bij "action" "masquerade" en klik op "ok".

Sluit nu beide routers aan via ether1 aan een switch. Nu kunnen we controleren of alles goed werkt.

Controle

Op de master router voer je deze controle uit.

/interface vrrp print
  • RM name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:31 arp=enabled interface=ether1 vrid=49
  • priority=254 interval=1 preemption-mode=yes authentication=none password="" on-backup=""
  • on-master=""

Op de backup router voer je deze controle eveneens uit.

/interface vrrp print
  • B name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:31 arp=enabled interface=ether1 vrid=49
  • priority=100 interval=1 preemption-mode=yes authentication=none password=""
  • on-backup="" on-master="

Als de configuratie is geslaagd moet het MAC-adres bij de master en backup router hetzelfde zijn.

Top