Wirelessinfo.be

Mikrotik routerboard, draadloos verbinden met een accesspoint

routerboard 751G

Dit voorbeeld is uitgevoerd op een RB 951G-2HnD Het mikrotik routerboard gaat draadloos verbinden met een accesspoint, alle ethernet poorten staan in switch modus. Er is een bridge aangemaakt waarin de master interface ether1 is geplaatst. Op de bridge is een DHCP-server geconfigureerd. Op iedere ethernet interface kan een computer of laptop worden aangesloten. Tussen de wlan en alle ethernet poorten is nat geconfigureerd.

RouterOs Bios firmware
6.33 3.24

Ether interfaces als switch configureren.
bridgen van de interfaces

  1. Log in met winbox en klik op "interfaces".
  2. Dubbelklik op ether5.

bridgen van de interfaces

  1. Bij "master port" selecteer ether1.
  2. Klik op "ok". Herhaal dit ook voor ether 2,3,4 zodat ether1 voor alle overige interfaces de master poort is.
Bridge aanmaken
bridgen van de interfaces

  1. Klik op het hoofdvenster op "bridge".
  2. Klik op het blauwe kruisje om een bridge aan te maken.

bridgen van de interfaces

  1. Bij "name" geef de bridge een naam.
  2. Klik op "ok".

bridgen van de interfaces

  1. Klik op het onderkopje "ports", klik op het blauwe kruisje.
  2. Bij "interface" selecteer "ether1" die als master fungeert voor alle interfaces.
  3. Klik op "ok".

Bridge IP-adres geven

  1. Klik in het hoofdvenster op "IP".
  2. Vervolgens klik je op "addresses".

  1. Klik op het blauwe kruisje.
  2. Bij "interface" selecteer "bridge_local".
  3. Bij "address" geef de bridge een IP-adres met een /24
  4. Klik op "ok".

Instellen van DHCP-server

  1. Klik op "IP".
  2. Vervolgens klik je op "DHCP-server"

Klik op "DHCP setup".

  1. Bij "DHCP-server interface" selecteer "bridge_local".
  2. Klik op "next".

Als alles goed is ingesteld wordt alles automatisch ingevuld, je moet steeds bevestigen met "next".

Bij "gateway for DHCP network" Klik op "next".

Kies hier hoeveel ip-adressen er moeten worden uitgedeeld, of laat die onaangeroerd, klik op "next".

Bij "DNS-servers" geef het IP-adres van het routerboard in en een reserve DNS-server. In dit voorbeeld google DNS. Klik op "next"

Hiermee bepaal je de lease duur, dit wil zeggen, de duur dat een ip-adress zal gereserveerd worden voor een client. klik op "next".

De DHCP-server is ingesteld. Klik op "ok".

DNS instellingen configureren

  1. Klik op "IP".
  2. Klik op "DNS".

  1. Bij "Servers" vul het IP-adres in van een DNS-server. Als voorbeeld neem ik deze van Google
  2. Geef een tweede DNS-server in.
  3. Vink "allow remote requests" aan.
  4. Klik vervolgens op "static"

  1. Klik op het blauwe kruisje.
  2. Geef een naam op.
  3. Vul het IP-adres van de router in.
  4. Klik op "ok".

Klik op het kruisje om het venster af te sluiten.

Klik op "ok".

Nat instellingen configureren

  1. Klik op "IP"
  2. Klik vervolgens op "firewall".

  1. Klik op het onderkopje "nat".
  2. Klik op het blauwe kruisje.

  1. Bij "chain" selecteer je "srcnat"
  2. Vul het netwerk IP-adres in van de IP-range van de local_bridge.
  3. Als "out interface" selecteer je "wlan1".
  4. Klik op het onderkopje "action"

  1. Bij "action" selecteer "masquerade".
  2. Klik op "ok". Sluit het firewall venster.

Wireless settings
p>

  1. Klik in het hoofdvenster op "wireless".
  2. Klik op het onderkopje "interfaces".
  3. Dubbelklik op interface "wlan1".

Klik op "wireless" vervolgens op "advanced mode".

  1. Bij "country" selecteer het land waarin u zich bevind.
  2. Klik op "scan" om naar draadloze netwerken te scannen.

  1. Selecteer het draadloze netwerk en klik op "connect".
  2. Klik op "ok".

Als je op een beveiligd accesspoint moet verbinden moet je eerst een security profile aanmaken.

Sluit de vensters af met op het kruisje te klikken.

Security profile aanmaken

  1. Klik op het hoofdvenster op "wireless".
  2. Vervolgens op "security profiles".

  1. Bij "name" geef de profile een naam.
  2. Bij "authentication types" vink de benodigde types aan. Ook de benodigde "unicast siphers" vink je aan.
  3. Vul de sleutel in van het accesspoint.
  4. Klik op "ok".

  1. Klik op de interface "wlan1".
  2. Klik op het onderkopje "wireless".
  3. Bij "security profile" selecteer de profile die je hebt aangemaakt.
  4. Klik op "scan" en verbind met het accesspoint naar keuze.

DHCP-client instellen.

  1. Klik op "IP".
  2. Vervolgens op "DHCP-client".

  1. Klik op het blauwe kruisje en bij "interface" selecteer "wlan1".
  2. Klik op "ok".

Als de wireless verbinding tot stand is gebracht krijg je nu een IP-adres toegekent van het accesspoint en kan je aan de slag.

Export van de configuratie

Voor de mensen die de configuratie niet zelf willen maken zet ik de code hier online. Het volstaat het Mikrotik routerboard te resetten zonder de standaard configuratie in de code te plakken in het "new terminal venster".

Wireless client met RB951G-2HnD
  • /interface bridge
  • add name=bridge_local
  • /interface wireless
  • set [ find default-name=wlan1 ] band=2ghz-b/g/n country=belgium disabled=no frequency=2437 ssid=\ Wirelessinfo.be
  • /interface ethernet
  • set [ find default-name=ether2 ] master-port=ether1
  • set [ find default-name=ether3 ] master-port=ether1
  • set [ find default-name=ether4 ] master-port=ether1
  • set [ find default-name=ether5 ] master-port=ether1
  • /ip pool
  • add name=dhcp_pool1 ranges=192.168.100.2-192.168.100.254
  • /ip dhcp-server
  • add address-pool=dhcp_pool1 disabled=no interface=bridge_local lease-time=1d name=dhcp1
  • /interface bridge port
  • add bridge=bridge_local interface=ether1
  • /ip address
  • add address=192.168.100.1/24 interface=bridge_local network=192.168.100.0
  • /ip dhcp-client
  • add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=wlan1
  • /ip dhcp-server network
  • add address=192.168.100.0/24 dns-server=192.168.100.1,8.8.8.8 gateway=192.168.100.1
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
  • /ip dns static
  • add address=192.168.100.1 name=router.thuis
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=wlan1 src-address=192.168.100.0/24
  • /system clock
  • set time-zone-name=Europe/Brussels
  • /system leds
  • set 0 interface=wlan1
  • /tool romon port
  • set [ find default=yes ] cost=100 forbid=no interface=all secrets=""

Opgelet! De configuratie is gemaakt met standaard paswoord. Je moet deze nog instellen. Wireless settings moeten aangepast worden zoals SSID en draadloze beveiliging.
Top