WirelessInfo.be informatie over bedrade en draadloze netwerken
In en uitschakelen van de Mikrotik interfaces door een script

In en uitschakelen van de Mikrotik interfaces

Dit script kan gebruikt worden zowel in scheduler, netwatch of in het terminal venster.

Ethernet interface in en uit schakelen

Ethernet interface ON
/interface ethernet enable ether1

Ethernet interface OFF
/interface ethernet disable ether1

Wireless interface

Wireless interface ON
/interface wireless enable wlan1

Wireless interface OFF
/interface wireless disable wlan1

Automatisch uit en aan zetten

Wireless interface OFF en ON

/interface wireless disable wlan1;

:delay 5s;

/interface wireless enable wlan1;

Dit script kan je bijvoorbeeld in netwatch gebruiken bij point to point links. Als de draadloze link niet meer werkt kan je beide stations laten herverbinden door netwatch de IP-adressen van de wireless interface te laten pingen. Bij geen reactie zal netwatch de wireless interfaces van beide stations 5 seconden uitschakelen en terug inschakelen. Dit kan de link automatsch herstellen.

Dagelijks aan en uit zetten van de wireless interface met scheduler

Wireless interface OFF en ON met scheduler

/system scheduler

add interval=1d name=schedule_wlan-on on-event=\

"/interface wireless enable wlan1" start-date=aug/04/2015 start-time=\ 07:00:00

add interval=1d name=schedule_wlan-off on-event=\

"/interface wireless disable wlan1" start-date=aug/04/2015 start-time=\ 22:00:00

Top