WirelessInfo.be informatie over bedrade en draadloze netwerken
Mikrotik bruikbare configuraties

Mikrotik bruikbare configuraties

De bedoeling van deze pagina is om de onervaren Mikrotik Routerboard gebruikers kant en klare configuraties voor te schotelen die gemakkelijk zijn toe te passen. Je dient wel het Routerboard te resetten zonder default configuratie. Na de reset open "winbox" log in op het Routerboard en plak de code in het "new terminal" venster, herstart en de gekozen configuratie doet zijn werk.

Het kan zijn dat je tijdens het plakken van de configuratie de verbinding met het routerboard verliest. Plak dan nogmaals de code in het "new terminal" venster.

Opgelet! Respecteer de wettelijke bepalingen van uw land wat Wi-Fi betreft. Pas de land instellingen aan conform de wetgeving van het land waarin u zich bevind. Deze configuraties zijn puur basic en hebben nog de standaard login en geen draadloze beveiliging geconfigureerd. Je moet deze nog aanpassen aan uw wensen.

routerboard 751G

Configuratie 1

Dit voorbeeld is geconfigureerd op het RB951G-2HnD en kan voor de Routerboarden RB951G-2HnD, RB791G-2HnD worden gebruikt.

Het routerboard heeft default instellingen maar heeft een extra accespoint met als ssid "guest". Dit maakt het mogelijk om gasten draadloos op uw gast netwerk te laten inloggen om van internet gebruik te maken zonder dat ze in uw prive netwerk zitten. Dit komt omdat ze in een andere IP-range zitten en uw prive netwerk wordt afgeschermd door middel van een firewall rule van het gast netwerk. In dit voorbeeld is geen draadloze beveiliging voorzien, dit moet je nog instellen. Hoe je dat moet doen zie je hier.

Configuratie 1 RB951G-2HnD
  • /interface bridge
  • add name=bridge-guest
  • add admin-mac=4C:5E:0C:EB:19:31 auto-mac=no name=bridge-local
  • /interface wireless
  • set [ find default-name=wlan1 ] band=2ghz-b/g/n country=belgium disabled=no \
  • distance=indoors frequency=2452 mode=ap-bridge name=wlan-private ssid=\
  • private wireless-protocol=802.11 wps-mode=disabled
  • /interface ethernet
  • set [ find default-name=ether1 ] name=ether1-gateway
  • set [ find default-name=ether2 ] name=ether2-master-local
  • set [ find default-name=ether3 ] master-port=ether2-master-local name=\
  • ether3-slave-local
  • set [ find default-name=ether4 ] master-port=ether2-master-local name=\
  • ether4-slave-local
  • set [ find default-name=ether5 ] master-port=ether2-master-local name=\
  • ether5-slave-local
  • /ip neighbor discovery
  • set ether1-gateway discover=no
  • /interface wireless
  • add disabled=no keepalive-frames=disabled mac-address=4E:5E:0C:EB:19:35 \
  • master-interface=wlan-private multicast-buffering=disabled name=wlan-guest \
  • ssid=guest wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
  • /ip pool
  • add name=dhcp_pool-private ranges=192.168.88.10-192.168.88.254
  • add name=dhcp_pool-guest ranges=192.168.89.2-192.168.89.254
  • /ip dhcp-server
  • add address-pool=dhcp_pool-private disabled=no interface=bridge-local name=\
  • dhcp-private
  • add address-pool=dhcp_pool-guest disabled=no interface=bridge-guest lease-time=\
  • 1d name=dhcp-guest
  • /interface bridge port
  • add bridge=bridge-local interface=ether2-master-local
  • add bridge=bridge-local interface=wlan-private
  • add bridge=bridge-guest interface=wlan-guest
  • /ip address
  • add address=192.168.88.1/24 comment="default configuration" interface=\
  • bridge-local network=192.168.88.0
  • add address=192.168.89.1/24 interface=bridge-guest network=192.168.89.0
  • /ip dhcp-client
  • add comment="default configuration" dhcp-options=hostname,clientid disabled=no \
  • interface=ether1-gateway
  • /ip dhcp-server network
  • add address=192.168.88.0/24 comment="default configuration" dns-server=\
  • 8.8.8.8,8.8.4.4 gateway=192.168.88.1 netmask=24
  • add address=192.168.89.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.89.1
  • /ip dns
  • set allow-remote-requests=yes
  • /ip dns static
  • add address=192.168.88.1 name=router
  • /ip firewall filter
  • add chain=input comment="default configuration" protocol=icmp
  • add chain=input comment="default configuration" connection-state=\
  • established,related
  • add action=drop chain=input comment="default configuration" in-interface=\
  • ether1-gateway
  • add action=fasttrack-connection chain=forward comment="default configuration" \
  • connection-state=established,related
  • add chain=forward comment="default configuration" connection-state=\
  • established,related
  • add action=drop chain=forward comment="default configuration" connection-state=\
  • invalid
  • add action=drop chain=forward dst-address=192.168.88.0/24 src-address=192.168.89.0/24 connection-nat-state=!dstnat connection-state=new in-interface=\
  • ether1-gateway
  • /ip firewall nat
  • add action=masquerade chain=srcnat comment="default configuration" \
  • out-interface=ether1-gateway
  • /system clock
  • set time-zone-name=Europe/Brussels
  • /system leds
  • set 0 interface=wlan-private
  • /tool mac-server
  • set [ find default=yes ] disabled=yes
  • add interface=ether2-master-local
  • add interface=ether3-slave-local
  • add interface=ether4-slave-local
  • add interface=ether5-slave-local
  • add interface=wlan-private
  • add interface=bridge-local
  • /tool mac-server mac-winbox
  • set [ find default=yes ] disabled=yes
  • add interface=ether2-master-local
  • add interface=ether3-slave-local
  • add interface=ether4-slave-local
  • add interface=ether5-slave-local
  • add interface=wlan-private
  • add interface=bridge-local

Configuratie 2

routerboard 751G

In dit voorbeeld maakt de draadloze interface van het Routerboard verbinding met een accesspoint of hotspot. Op de ethernet interfaces 1 tot 5 kan je door middel van een netwerkkabel uw PC of laptop aansluiten. Er is NAT geconfigureert tussen de wireless en de ethernet interfaces, de ethernet interfaces zijn gebridged met elkaar. Op de bridge is een DHCP-server geconfigureerd die de IP-adressen gaat uitdelen aan de toestellen die verbonden gaan worden op de ethernet interfaces.

Wireless client met RB951G-2HnD
  • /interface bridge
  • add name=bridge_local
  • /interface wireless
  • set [ find default-name=wlan1 ] band=2ghz-b/g/n country=belgium disabled=no frequency=2437 ssid=\ Wirelessinfo.be
  • /interface ethernet
  • set [ find default-name=ether2 ] master-port=ether1
  • set [ find default-name=ether3 ] master-port=ether1
  • set [ find default-name=ether4 ] master-port=ether1
  • set [ find default-name=ether5 ] master-port=ether1
  • /ip pool
  • add name=dhcp_pool1 ranges=192.168.100.2-192.168.100.254
  • /ip dhcp-server
  • add address-pool=dhcp_pool1 disabled=no interface=bridge_local lease-time=1d name=dhcp1
  • /interface bridge port
  • add bridge=bridge_local interface=ether1
  • /ip address
  • add address=192.168.100.1/24 interface=bridge_local network=192.168.100.0
  • /ip dhcp-client
  • add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=wlan1
  • /ip dhcp-server network
  • add address=192.168.100.0/24 dns-server=192.168.100.1,8.8.8.8 gateway=192.168.100.1
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
  • /ip dns static
  • add address=192.168.100.1 name=router.thuis
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=wlan1 src-address=192.168.100.0/24
  • /system clock
  • set time-zone-name=Europe/Brussels
  • /system leds
  • set 0 interface=wlan1
  • /tool romon port
  • set [ find default=yes ] cost=100 forbid=no interface=all secrets=""

Configuratie 3

routerboard 751G

Een speciale toepassing voor mensen die op boten leven die aan de kade liggen. Een Mikrotik Groove A-52HPn waarop een omnidirectionele antenne is gemonteerd gaat fungeren als draadloze client die gaat verbinden met een accesspoint of hotspot. Die wordt buiten gemonteerd op de mast bijvoorbeeld. Met een netwerkkabel verbindt je de Groove naar het Routerboard dat binnen staat. Binnen maken we gebruik van het Routerboard RB951G-2HnD. Deze wordt geconfigureerd als een accesspoint waarop uw PC, laptop en dergelijke meer kan laten verbinden. Op de ethernet interfaces 2 tot 5kan je ook uw PC of laptop bekabeld aansluiten. Op het Routerboard Groove is de Wlan interface de WAN interface, ether1 is de LAN interface waarop een DHCP-server is geconfigureerd. Tussen de WAN en LAN interface is NAT geconfigureerd. Op het Routerboard RB951G-2HnD is een bridge aangemaakt. Op de bridge zitten de ethernet poorten 1 tot 5 en de Wireless interface. Ether 1 wordt gebruikt om de Mikrotik Groove A-52HPn aan te sluiten die buiten gemonteerd is. Ether 2 tot 5 kan je gebruiken om netwerktoestellen bekabeld aan te sluiten op het Routerboard.

Groove A-52HPn
  • /interface wireless
  • set [ find default-name=wlan1 ] antenna-gain=6 band=2ghz-b country=belgium \
  • disabled=no frequency=2422 mode=station-bridge ssid=WirelessInfo wps-mode=disabled
  • /ip pool
  • add name=dhcp_pool1 ranges=192.168.100.2-192.168.100.254
  • /ip dhcp-server
  • add address-pool=dhcp_pool1 disabled=no interface=ether1 lease-time=1d name=dhcp1
  • /ip address
  • add address=192.168.100.1/24 interface=ether1 network=192.168.100.0
  • /ip dhcp-client
  • add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
  • interface=wlan1
  • /ip dhcp-server network
  • add address=192.168.100.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.100.1
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=wlan1 src-address=192.168.100.0/24
  • /system clock
  • set time-zone-name=Europe/Brussels
  • /system leds
  • set 0 interface=wlan1
  • /system routerboard settings
  • set cpu-frequency=600MHz
  • /tool romon port
  • set [ find default=yes ] cost=100 forbid=no interface=all secrets=""

RB951G-2HnD
  • /interface bridge
  • add name=bridge_local
  • /interface wireless
  • set [ find default-name=wlan1 ] antenna-gain=5 country=belgium disabled=no \
  • mode=ap-bridge ssid=MikroTik-test
  • /interface bridge port
  • add bridge=bridge_local interface=ether1
  • add bridge=bridge_local interface=ether2
  • add bridge=bridge_local interface=ether3
  • add bridge=bridge_local interface=ether4
  • add bridge=bridge_local interface=ether5
  • add bridge=bridge_local interface=wlan1
  • /ip dhcp-client
  • add default-route-distance=0 disabled=no interface=bridge_local
  • /system clock
  • set time-zone-name=Europe/Brussels
  • /system leds
  • set 0 interface=wlan1

RB2011 UAS-RM

routerboard 2011

Dit voorbeeld is geconfigureerd op het RB2011 UAS-RM

Configuratie 4

configuratie4

Het Routerboard RB2011 UAS-RM heeft op de ethernet interfaces 1.2.3.4.5 een private lan geconfigureert. Deze zitten in een bridge "bridge_private" samen met een VLAN interface die op de Mikrotik Groove A-52HPn de SSID "private" zal verzorgen. De Groove wordt verbonden met ether10 en zal dienst doen als trunk om de twee VLAN's aan te sturen. De interface ether6 is de WAN poort waar je de modem van uw internet provider moet mee verbinden. Deze heeft een DHCP-client configuratie die een IP-adres zal aanvragen aan de modem van uw provider. De neighbor discovery op de WAN is uitgeschakeld om veiligheid redenen. De overige ethernet interfaces 7 en 8 staan in de "bridge_guest" ether9 is vrijgehouden en koppel ik mijn netwerkkabel aan voor de configuratie in te laden. De Groove gaat twee SSID's uitzenden, namelijk "guest" en "private". Deze zitten allebei in een afzonderlijk netwerk zodat de guest niet op het private netwerk geraakt. Daar zorgt een firewall rule voor op het Routerboard RB2011 UAS-RM.

Groove A-52HPn
  • /interface bridge
  • add name=bridge_guest
  • add name=bridge_private
  • /interface wireless
  • set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=2442 mode=ap-bridge name=wlan_guest ssid=guest
  • add disabled=no mac-address=D6:CA:6D:1F:98:8D master-interface=wlan_guest name=wlan_private ssid=private
  • /interface ethernet
  • set [ find default-name=ether1 ] name=ether1_trunk
  • /interface vlan
  • add interface=ether1_trunk l2mtu=1596 name=vlan_guest vlan-id=100
  • add interface=ether1_trunk l2mtu=1596 name=vlan_private vlan-id=200
  • /interface bridge port
  • add bridge=bridge_private interface=vlan_private
  • add bridge=bridge_private interface=wlan_private
  • add bridge=bridge_guest interface=vlan_guest
  • add bridge=bridge_guest interface=wlan_guest
  • /system leds
  • set 0 interface=wlan_guest
  • /system routerboard settings
  • set cpu-frequency=600MHz
  • /tool romon port
  • set [ find default=yes ] cost=100 forbid=no interface=all secrets=""

Opgelet! Respecteer de wettelijke bepalingen van uw land wat Wi-Fi betreft. Pas de land instellingen aan conform de wetgeving van het land waarin u zich bevind. Er zijn nog geen draadloze beveiligingen aanwezig, vergeet deze niet te configureren op de Groove. Dit voorbeeld is gemaakt met een Groove A-52HPn als je andere toestellen gebruikt let op de CPU snelheid van uw device bij "set cpu-frequency=600MHz" zal je de snelheid moeten aanpassen anders kan het zijn dat je de CPU overclockt met schade als gevolg.

RB2011 UAS-RM
  • /interface bridge
  • add name=bridge_guest
  • add name=bridge_private
  • /interface ethernet
  • set [ find default-name=ether1 ] name=ether1_private
  • set [ find default-name=ether2 ] master-port=ether1_private name=ether2_private
  • set [ find default-name=ether3 ] master-port=ether1_private name=ether3_private
  • set [ find default-name=ether4 ] master-port=ether1_private name=ether4_private
  • set [ find default-name=ether5 ] master-port=ether1_private name=ether5_private
  • set [ find default-name=ether6 ] name=ether6_wan
  • set [ find default-name=ether7 ] name=ether7_guest
  • set [ find default-name=ether8 ] master-port=ether7_guest name=ether8_guest
  • set [ find default-name=ether10 ] name=ether10_trunk
  • /ip neighbor discovery
  • set ether6_wan discover=no
  • /interface vlan
  • add interface=ether10_trunk l2mtu=1594 name=vlan_guest vlan-id=100
  • add interface=ether10_trunk l2mtu=1594 name=vlan_private vlan-id=200
  • /ip pool
  • add name=dhcp_pool-guest ranges=192.168.100.2-192.168.100.254
  • add name=dhcp_pool-private ranges=192.168.101.2-192.168.101.254
  • /ip dhcp-server
  • add address-pool=dhcp_pool-guest disabled=no interface=bridge_guest lease-time=1d name=dhcp_guest
  • add address-pool=dhcp_pool-private disabled=no interface=bridge_private lease-time=1d name=dhcp_private
  • /interface bridge port
  • add bridge=bridge_private interface=ether1_private
  • add bridge=bridge_guest interface=ether7_guest
  • add bridge=bridge_guest interface=vlan_guest
  • add bridge=bridge_private interface=vlan_private
  • /ip address
  • add address=192.168.100.1/24 interface=bridge_guest network=192.168.100.0
  • add address=192.168.101.1/24 interface=bridge_private network=192.168.101.0
  • /ip dhcp-server network
  • add address=192.168.100.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.100.1
  • add address=192.168.101.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.101.1
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=ether6_wan
  • /system lcd
  • set contrast=0 enabled=no port=parallel type=24x4
  • /system lcd page
  • set time disabled=yes display-time=5s
  • set resources disabled=yes display-time=5s
  • set uptime disabled=yes display-time=5s
  • set packets disabled=yes display-time=5s
  • set bits disabled=yes display-time=5s
  • set version disabled=yes display-time=5s
  • set identity disabled=yes display-time=5s
  • set bridge_guest disabled=yes display-time=5s
  • set bridge_private disabled=yes display-time=5s
  • set sfp1 disabled=yes display-time=5s
  • set ether1_private disabled=yes display-time=5s
  • set ether2_private disabled=yes display-time=5s
  • set ether3_private disabled=yes display-time=5s
  • set ether4_private disabled=yes display-time=5s
  • set ether5_private disabled=yes display-time=5s
  • set ether6_wan disabled=yes display-time=5s
  • set ether7_guest disabled=yes display-time=5s
  • set ether8_guest disabled=yes display-time=5s
  • set ether9_guest disabled=yes display-time=5s
  • set ether10_trunk disabled=yes display-time=5s
  • set vlan_guest disabled=yes display-time=5s
  • set vlan_private disabled=yes display-time=5s
  • /tool romon port
  • set [ find default=yes ] cost=100 forbid=no interface=all secrets=""
  • /ip firewall filter
  • add action=drop chain=forward dst-address=192.168.101.0/24 src-address=192.168.100.0/24

Configuratie 5

Dubbel WAN failover met load balancing

configuratie4

Het Routerboard RB951G-2HnD heeft 2 WAN aansluitingen (ether1 en ether2) waardoor het mogelijk wordt om load balacing en WAN failover uit te voeren. De MAC discovery is uitgeschakeld op beide WAN interfaces. Op de WAN interfaces is DHCP-client actief zodat het Routerboard een IP-adres krijgt toegewezen van uw internet provider. Er is een bridge (Bridge_local) geconfigureerd waarin ether 3,4 en 5 is geplaatst. Daarop is een DHCP-server actief. Deze interfaces zijn de LAN interfaces en heeft de IP-range 192.168.100.0/24 NAT is geconfigureert tussen beide WAN interfaces en het LAN netwerk.

Als er veel internet verkeer is op uw netwerk gaat deze configuratie ervoor zorgen dat het data verkeer niet allemaal naar eenzelfde provider gaat. Het data verkeer zal opgesplitst worden tussen WAN1 en WAN2. Zo zal WAN1 niet worden belast met al het data verkeer. Nog een punt is als WAN1 moest uitvallen door een defect zal het data verkeer worden omgeleid naar WAN2.

Opgelet! Bepaalde instellingen zullen moeten worden aangepast zoals de IP-adressen van de gateways anders werkt het niet. Het beste kopieer je de code, en plak je deze eerst in wordpad of een andere tekst editor om de code eerst aan te passen naargelang uw netwerk. De rode IP-adressen in de code moet door jou worden aangepast. Gebruik "ether5" om de verbinding tussen uw Routerboard en de PC te verwezenlijken anders kan je de code nooit uploaden. De interface "ether5" moet dan nog in slave mode worden gezet met als master "ether3_local".

RB951G-2HnD
  • /interface bridge
  • add name=bridge_local
  • /interface wireless
  • set [ find default-name=wlan1 ] band=2ghz-b/g/n country=belgium disabled=no mode=ap-bridge ssid=WirelessInfo
  • /interface ethernet
  • set [ find default-name=ether1 ] name=ether1_WAN1
  • set [ find default-name=ether2 ] name=ether2_WAN2
  • set [ find default-name=ether3 ] name=ether3_Local
  • set [ find default-name=ether4 ] master-port=ether3_Local name=ether4_Local
  • /ip neighbor discovery
  • set ether1_WAN1 discover=no
  • set ether2_WAN2 discover=no
  • /ip pool
  • add name=dhcp_pool1 ranges=192.168.100.2-192.168.100.254
  • /ip dhcp-server
  • add address-pool=dhcp_pool1 disabled=no interface=bridge_local lease-time=1d name=dhcp1
  • /interface bridge port
  • add bridge=bridge_local interface=ether3_Local
  • add bridge=bridge_local interface=wlan1
  • /ip address
  • add address=192.168.100.1/24 interface=bridge_local network=192.168.100.0
  • /ip dhcp-client
  • add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1_WAN1
  • add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether2_WAN2
  • /ip dhcp-server network
  • add address=192.168.100.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.100.1
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
  • /ip firewall mangle
  • add action=mark-connection chain=input in-interface=ether1_WAN1 new-connection-mark=WAN1_conn
  • add action=mark-connection chain=input in-interface=ether2_WAN2 new-connection-mark=WAN2_conn
  • add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1
  • add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2
  • add chain=prerouting dst-address=192.168.0.0/24 in-interface=bridge_local
  • add chain=prerouting dst-address=10.90.69.0/24 in-interface=bridge_local
  • add action=mark-connection chain=prerouting dst-address-type=!local in-interface=bridge_local new-connection-mark=WAN2_conn per-connection-classifier=both-addresses-and-ports:2/1
  • add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=bridge_local new-routing-mark=to_WAN1
  • add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=bridge_local new-routing-mark=to_WAN2
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=ether1_WAN1
  • add action=masquerade chain=srcnat out-interface=ether2_WAN2
  • /ip route
  • add check-gateway=ping distance=1 gateway=192.168.0.1 routing-mark=to_WAN1
  • add check-gateway=ping distance=1 gateway=10.90.69.10 routing-mark=to_WAN2
  • add check-gateway=ping distance=1 gateway=192.168.0.1
  • add check-gateway=ping distance=2 gateway=10.90.69.10
  • /system clock
  • set time-zone-name=Europe/Brussels
  • /system leds
  • set 0 interface=wlan1
  • /tool romon port
  • set [ find default=yes ] cost=100 forbid=no interface=all secrets=""

routerboard 2011

Dezelfde overflow en load balancing configuratie maar met het RB2011 UAS-RM

Het Routerboard RB2011 UAS-RM heeft 2 WAN aansluitingen (ether6 en ether7) waardoor het mogelijk wordt om load balacing en WAN failover uit te voeren. De MAC discovery is uitgeschakeld op beide WAN interfaces. Op de WAN interfaces is DHCP-client actief zodat het Routerboard een IP-adres krijgt toegewezen van uw internet provider. Er is een bridge (Bridge_local) geconfigureerd waarin ether 1,2,3,4,5,8,9 is geplaatst. Daarop is een DHCP-server actief. Deze interfaces zijn de LAN interfaces en heeft de IP-range 192.168.100.0/24 NAT is geconfigureert tussen beide WAN interfaces en het LAN netwerk. Ether10 staat los van alles, daarop moet je met uw PC verbinden om deze config in het Routerboard te laden. Doe je dat niet verlies je de verbinding met het Routerboard ergens halverwege en blijft die hangen.

Opgelet! Bepaalde instellingen zullen moeten worden aangepast zoals de IP-adressen van de gateways anders werkt het niet. Het beste kopieer je de code, en plak je deze eerst in wordpad of een andere tekst editor om de code eerst aan te passen naargelang uw netwerk. De rode IP-adressen in de code moet door jou worden aangepast. Gebruik "ether10" om de verbinding tussen uw Routerboard en de PC te verwezenlijken anders kan je de code nooit uploaden. De interface "ether10" kan dan nog in slave mode worden gezet met als master "ether8_local".

RB2011 UAS-RM
  • /interface bridge
  • add name=bridge_local
  • /interface ethernet
  • set [ find default-name=ether1 ] name=ether1_local
  • set [ find default-name=ether2 ] master-port=ether1_local name=ether2_local
  • set [ find default-name=ether3 ] master-port=ether1_local name=ether3_local
  • set [ find default-name=ether4 ] master-port=ether1_local name=ether4_local
  • set [ find default-name=ether5 ] master-port=ether1_local name=ether5_local
  • set [ find default-name=ether6 ] name=ether6_wan1
  • set [ find default-name=ether7 ] name=ether7_wan2
  • set [ find default-name=ether8 ] name=ether8_local
  • set [ find default-name=ether9 ] master-port=ether8_local name=ether9_local
  • /ip neighbor discovery
  • set ether6_wan1 discover=no
  • set ether7_wan2 discover=no
  • /ip pool
  • add name=dhcp_pool1 ranges=192.168.100.2-192.168.100.254
  • /ip dhcp-server
  • add address-pool=dhcp_pool1 disabled=no interface=bridge_local lease-time=1d name=dhcp1
  • /interface bridge port
  • add bridge=bridge_local interface=ether1_local
  • /ip address
  • add address=192.168.100.1/24 interface=bridge_local network=192.168.100.0
  • /ip dhcp-client
  • add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether6_wan1
  • add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether7_wan2
  • /ip dhcp-server network
  • add address=192.168.100.0/24 dns-server=192.168.100.1,8.8.8.8,8.8.4.4 gateway=192.168.100.1 netmask=24
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
  • /ip dns static
  • add address=192.168.100.1 name=router.home ttl=1w3d
  • /ip firewall mangle
  • add action=mark-connection chain=input in-interface=ether6_wan1 new-connection-mark=WAN1_conn
  • add action=mark-connection chain=input in-interface=ether7_wan2 new-connection-mark=WAN2_conn
  • add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1
  • add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2
  • add chain=prerouting dst-address=192.168.0.0 in-interface=bridge_local
  • add chain=prerouting dst-address=10.90.69.0 in-interface=bridge_local
  • add action=mark-connection chain=prerouting dst-address-type=!local in-interface=bridge_local new-connection-mark=WAN2_conn per-connection-classifier=both-addresses-and-ports:2/1
  • add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=bridge_local new-routing-mark=to_WAN1
  • add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=bridge_local new-routing-mark=to_WAN2
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=ether6_wan1
  • add action=masquerade chain=srcnat out-interface=ether7_wan2
  • /ip route
  • add check-gateway=ping distance=1 gateway=192.168.0.1 routing-mark=to_WAN1
  • add check-gateway=ping distance=1 gateway=10.90.69.10 routing-mark=to_WAN2
  • add check-gateway=ping distance=1 gateway=192.168.0.1
  • add check-gateway=ping distance=2 gateway=10.90.69.10
  • /system clock
  • set time-zone-name=Europe/Brussels
  • /system lcd
  • set contrast=0 enabled=no port=parallel type=24x4
  • /system lcd page
  • set time disabled=yes display-time=5s
  • set resources disabled=yes display-time=5s
  • set uptime disabled=yes display-time=5s
  • set packets disabled=yes display-time=5s
  • set bits disabled=yes display-time=5s
  • set version disabled=yes display-time=5s
  • set identity disabled=yes display-time=5s
  • set bridge_local disabled=yes display-time=5s
  • set sfp1 disabled=yes display-time=5s
  • set ether1_local disabled=yes display-time=5s
  • set ether2_local disabled=yes display-time=5s
  • set ether3_local disabled=yes display-time=5s
  • set ether4_local disabled=yes display-time=5s
  • set ether5_local disabled=yes display-time=5s
  • set ether6_wan1 disabled=yes display-time=5s
  • set ether7_wan2 disabled=yes display-time=5s
  • set ether8_local disabled=yes display-time=5s
  • set ether9_local disabled=yes display-time=5s
  • set ether10 disabled=yes display-time=5s
  • /tool romon port
  • set [ find default=yes ] cost=100 forbid=no interface=all secrets=""

Top