Wirelessinfo.be

Mikrotik routerboard SXT verbinden met hotspot

SXT verbinden met hotspot

RouterBoard RouterOs Bios firmware
SXT Lite2 6.20 3.19

Op een camping, jachthaven en zo meer verbinding maken met een hotspot is soms zeer omslachtig. In dit geval bied verbinding maken met een hotspot door middel van een Mikrotik SXT een oplossing. Ik geef hier een voorbeeld voor met de Telenet homespot te verbinden maar dat kan voor gelijk welke hotspot.

Hoe wordt de Mikrotik SXT geconfigureerd

De SXT zal geconfigureerd worden als router en zal door middel van de DHCP-server zelf IP-adressen uitdelen aan de clients. Het WAN (hier de wireless interface) en het LAN (de ethernet poort) gedeelte zal genat en gemaskeerd worden. Het wireless gedeelte zal verbinding maken met de hotspot. De ethernet interface wordt verbonden met een pc, switch of accesspoint.

Plak deze code in het terminalvenster van de Mikrotik SXT

Plak deze code in het terminalvenster van de SXT
  • /interface wireless
  • set [ find default-name=wlan1 ] band=5ghz-a/n disabled=no l2mtu=1600 ssid=TELENETHOMESPOT
  • /ip pool
  • add name=dhcp_pool1 ranges=192.168.100.2-192.168.100.254
  • /ip dhcp-server
  • add address-pool=dhcp_pool1 disabled=no interface=ether1 name=dhcp1
  • /ip address
  • add address=192.168.100.1/24 interface=ether1 network=192.168.100.0
  • /ip dhcp-client
  • add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=wlan1
  • /ip dhcp-server network
  • add address=192.168.100.0/24 gateway=192.168.100.1
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=wlan1 src-address=192.168.100.0/24
  • /ip upnp
  • set allow-disable-external-interface=no
  • /system leds set 0 interface=wlan1

Voor de mensen die de volledige configuratie zelf eens willen uitproberen

Het wireless gedeelte instellen

Klik in het hoofd menu op "wireless".

Schakel de wireless interface aan en dubbelklik op "wlan1". Klik vervolgens op "scan".

In dit voorbeeld verbind ik met een telenet homespot. Selecteer de gewenste SSID en klik op "connect".

Om te bevestigen klik op "ok".

DHCP-client op de wireless interface instellen

Klik op "IP" vervolgens op "DHCP-client".

Klik op het blauwe kruis om een DHCP-client aan te maken.

Selecteer "wlan1" klik op "ok".

De SXT krijgt een IP-adres toegewezen van de telenet homespot.

De ethernet interface een IP-adres geven en DHCP-server configureren.

Klik op "IP" vervolgens op "address".

Klik op het blauwe kruis.

Geef een door u gekozen IP-adres met als subnet /24 (255.255.255.0). Klik op "ok".

Klik in het hoofd menu terug op "IP" vervolgens op "DHCP-server".

Klik op "DHCP setup" en selecteer "ether1". Klik op "next".

De DHCP-address space komt automatisch tevoorschijn. Klik op "next".

De gateway wordt eveneens automatisch ingevuld. Klik op "next".

Pas de IP-range aan indien gewenst. Klik op "next".

De DNS-server IP-adressen komen automatisch tevoorschijn. Klik op "next".

Bij "lease time" pas naar behoeven de tijd aan hoelang een IP-adres wordt gereserveerd voor een client.

DHCP-server setup is voltooid.

Mikrotik SXT Natten en maskeren.

Klik op "IP" vervolgens op "firewall".

Klik op het tabblad "nat" en klik op het blauwe kruis.

  • Bij "chain" selecteer je "srcnat".
  • Bij "scr address" vul de volledige IP-range in zoals hier getoond.
  • Bij "out interface" selecteer je "wlan1".

Klik op het tabblad "action" en selecteer "masquerade". Klik op "ok".

De instellingen zijn gemaakt, je kan nu verbinden met de hotspot.

Zo, er is verbinding gemaakt en je kan aan de slag.

Top